Contar Celdas Con Texto En Excel

Excel a ~ budgetmedicals.net 365Excel hacia budgetmedicals.net 365 para MacExcel hacia la WebExcel 2019Excel 2016Excel dos mil diecinueve para MacExcel 2013Excel 2010Excel 2007Excel 2016 para MacExcel para Mac 2011Excel Starter 2010Más...Menos

Use CONTAR.SI, una después las subtraedación estadísticas, para conde el número de celda que seguir un criterio; vía ejemplo, para conde el número de veces los una ciudad determinada aparece en laa lista del clientes.

Estás mirando: Contar celdas con texto en excel

En su forma más sencilla, CONTAR.SI rápido lo siguiente:

no

=CONTAR.SI(¿Dónde quiere ejecución la búsqueda y qué quiere buscar?)

no

Por ejemplo:

=CONTAR.SI(A2:A5,"Londres")

no

=CONTAR.SI(A2:A5;A4)

no
*

CONTAR.SI(rango;criterios)

Nombre de argumento

Descripción

Rango (obligatorio)

El grupo de células que desea contar. Rango puede contener números, matrices, a rango alcanzan nombre o referencias ese contengan números. Los valores en blanco y después texto se ignoran.

Obtenga información sobre cómo escoger rangos dentro de una hoja.

Criterios (obligatorio)

Número, expresión, nota de celdas o cadena después texto que decidir las células que se van uno contar.

Por ejemplo, puede aprovechar un número qué 32, laa comparación como ">32", una células como B4 o la a palabra qué "manzanas".

CONTAR.SI usa solamente un criterio. Usar CONTAR.SI.CONJUNTO correcto desea usar varios criterios.


no

Ejemplos

Para aprovechar estos ejemplos después Excel, copie los contando de la tabla de abajo y péguelos dentro la celda A1 ese una nueva hoja ese cálculo.

no

Datos

Datos

no no

manzanas

32

naranjas

54

melocotones

75

manzanas

86

Fórmula

Descripción

=CONTAR.SI(A2:A5;"manzanas")

Cuenta los número del celdas alcanzan manzanas entre las celda A2 y A5. Ns resultado eliminar 2.

=CONTAR.SI(A2:A5;A4)

Cuenta el número después celdas con melocotones, los valor después A4, adelante las células A2 y A5. El resultado es 1.

=CONTAR.SI(A2:A5,A2)+CONTAR.SI(A2:A5,A3)

Cuenta los número de manzanas, ns valor después A2, y después naranjas, ns valor después A3, adelante las celdas A2 y A5. El resultado denominada 3. Es fórmula usa CONTAR.SI dos veces para precisar varios criterios, un estándar por expresión. ~ puede emplear la función CONTAR.SI.CONJUNTO.

=CONTAR.SI(B2:B5;">55")

Cuenta los número del celdas alcanzan un valor más alto a 55 entre las celda B2 y B5. El resultado eliminar 2.

=CONTAR.SI(B2:B5;""&B4)

Cuenta ns número del celdas alcanzan un valor diferente de setenta y cinco entre las células B2 y B5. Ns símbolo después la "y" (&) combinación el operador de comparar "" (no denominaciones igual a) y el valor ese B4 para leer =CONTAR.SI(B2:B5,"75"). Ns resultado denominaciones 3.

=CONTAR.SI(B2:B5;">=32")-CONTAR.SI(B2:B5;">85")

Cuenta los número del celdas con un valor más alto o capital a 32 e inferior o equidad a ochenta y cinco entre las celdas B2 y A5. Los resultado denominaciones 3.

=CONTAR.SI(A2:A5,"*")

Cuenta los número de celdas que contienen texto entre las células A2 y A5. El personalidad comodín * se usa para reemplazar alguna carácter. Ns resultado denominaciones 4.

=CONTAR.SI(A2:A5,"?????es")

Cuenta el número de células que tengo exactamente 7 caracteres y que terminan alcanzar las carta "es" todos las celda A2 y A5. El signo ese interrogación (?) se estados unidos como personaje comodín hacia coincidir con caracteres individuales. Ns resultado es 2.

no

Problemas comunes

no no

Problema

Qué ha fallado

no

Se devolvió a valor incorrecto para cadena largas.

La constan CONTAR.SI devuelve resultado incorrectos si se u.s.a. Para comparar cadenas de hasta luego de doscientos cincuenta y cinco caracteres.

Ver más: Partidos De Futbol Online En Vivo Online +>, Ver Fútbol Online

Para comparar cadenas de qué es más de doscientos cincuenta y cinco caracteres, use la función CONCATENAR o el operador concatenar &. Por ejemplo, =CONTAR.SI(A2:A5,"cadena larga"&"otra cadena larga").

No se devolvió ningún valor cuándo se esperaba uno.

Asegúrese de bloqueos el razonamiento de criterios entre comillas.

Una formula CONTAR.SI recibe un error #¡VALOR! al dar referencia a es diferente hoja después cálculo.

Este error se produce si la fórmula que contiene la función hace nota a células o uno un clasifica de uno libro cerrado y se calculan las celdas. A ~ que esta características funcione, los otro libro tengo que estar abierto.

Prácticas recomendadas

no

Realice esta procedimiento

no

¿Por qué?

Tenga en factura que CONTAR.SI aprobar por elevado mayúsculas y minúsculas en las cadenas de texto.

Los criterio no distinguen todos mayúsculas y minúsculas. Dentro otras palabras, la cadena "manzanas" y la cadena "MANZANAS" darán como resultado la misma al gusto de celdas.

Use caracteres comodín.

Los caracteres comodín, como el signo del interrogación (?) y asterisco (*), acudir usarse en criterios. Ns signo ese interrogación reemplaza cualquier personalidad individual. Los asterisco reemplaza alguna secuencia ese caracteres. Sí señor lo que desea busca es ns signo después interrogación o a asterisco, escriba laa tilde (~) antes del carácter.

Por ejemplo, =CONTAR.SI(A2:A5,"manzana?") contará todas los instancias de "manzana" alcanzar una última texto que pueden variar.

Asegúrese ese que ese datos alguno contienen caracteres incorrectos.

Al conde valores ese texto, definitivamente de que los datos alguna contienen espacial al principio ni al final, ese que alguna haya un uso incoherente de las comillas rectas (" o ") ni tipográficas (‘ o “) y después que alguno haya caracteres alguno imprimibles. En estos casos, CONTAR.SI puede devolver un valores inesperado o incorrecto.

Intente apalancamiento la constan LIMPIAR o la función ESPACIOS.

Para mayor comodidad, usar rangos alcanzar nombre.

CONTAR.SI acepta el uso de rangos alcanzar nombre dentro una fórmula (por ejemplo, =CONTAR.SI(fruta;">=32")-CONTAR.SI(fruta;">85"). El rango alcanzan nombre puede hacer estar dentro la hoja del cálculo actual, dentro de otra hoja después cálculo del mismo factbook o dentro de una hoja ese cálculo de otro libro. Para dar referencia a es diferente libro, ese libro también derecha estar abierto.


Nota: La función CONTAR.SI cuales contará celda según ns color ese la derivado o los fondo después la celda. Todavía Excel denominada compatible alcanzan funciones identificar por el cliente (UDF) alcanzan las operaciones después budgetmedicals.net intuitivo Basic para aplicaciones (VBA) en celdas muy famoso en los color después la derivado o ns fondo. Este denominada un ejemplo de de qué manera puede contando el número del celdas alcanzar un color de celdas específico con VBA.

Ver más: → Aprenda Como Cocinar Yuca Fresca, Cómo Cocina La Yuca


no

¿Necesitas hasta luego ayuda?

Siempre puede preguntar a uno experto dentro Excel tech Community, logrado soporte técnico dentro la comunidad de premio o sugerir una característica nueva o mejora en el UserVoice ese Excel.

no

Vea también

Para contando las células que no están dentro blanco, use la constan CONTARA.

Para conde las celdas mediante varios criterios, usar la constan CONTAR.SI.CONJUNTO

ver un vídeo acerca cómo usar la constan CONTAR.SI.CONJUNTO

La constan SUMAR.SI acabó suma los valores ese coinciden con un criterio único

La función SUMAR.SI.CONJUNTO acabó suma los valores que coinciden alcanzar varios estándar

constan SI.CONJUNTO (budgetmedicals.net 365, Excel 2016 y posterior)

use la función espacial para eliminar espacios inicial y finales de celda

use la constan LIMPIAR para suprimir caracteres alguno imprimibles de celda

Información general para fórmulas dentro de Excel

Cómo interruptor automático la ruptura ese las fórmulas

detectar errores en fórmulas

descendientes estadísticas

Funciones de Excel (por asignación alfabético)

Funciones del Excel (por categoría)

use SUMAR.SI, CONTAR.SI y otras funciones relacionadas para análisis los vergüenza rápidamente (versión preliminar gratuita)